summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAineopintojen-harjoitustyo-Algoritmit-j <github-hy-tiralabra@v.hix.fi>2024-01-13 17:43:17 +0200
committerAineopintojen-harjoitustyo-Algoritmit-j <github-hy-tiralabra@v.hix.fi>2024-01-13 17:43:17 +0200
commit227870a64f1eacbc13950256a05a2fab5c8c2a25 (patch)
tree1c3cae99e4c16fa8ae2fca6073a38bbf11104ac3 /pyproject.toml
parent9f7086628c58392b7bdc45f9f0994bfbd64b99c6 (diff)
Linting and docstringing board/board.py
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 90d7851..a471c2b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -12,7 +12,15 @@ python = "^3.10"
[tool.poetry.group.dev.dependencies]
pytest = "^7.4.4"
coverage = "^7.4.0"
+pylint = "^3.0.3"
+autopep8 = "^2.0.4"
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
+
+[tool.pylint.main]
+source-roots = "./"
+
+[tool.pylint.basic]
+docstring-min-length = 0