summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 11 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fd1ea78..ca26e7d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,9 +1,10 @@
[tool.poetry]
name = "miinaharava"
-version = "0.1.0"
+version = "0.1"
description = "Miinaharava ratkaisijalla"
authors = ["Aineopintojen-harjoitustyo-Algoritmit-j <github-hy-tiralabra@v.hix.fi>"]
readme = "README.md"
+packages = [ { include = "miinaharava", from = "src" } ]
[tool.poetry.dependencies]
python = "^3.10"
@@ -13,14 +14,18 @@ pytest = "^7.4.4"
coverage = "^7.4.0"
pylint = "^3.0.3"
+[tool.poetry.scripts]
+pylint = "dev:dev_pylint"
+pytest = "dev:dev_pytest"
+covhtml = "dev:dev_covhtml"
+covxml = "dev:dev_covxml"
+covff = "dev:dev_covff"
+all = "dev:dev_all"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
[tool.pylint.main]
recursive = true
-source-roots = ["./"]
-
-[tool.pylint.basic]
-
-[tool.pylint.messages]
+source-roots = ["src/miinaharava/"]