summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 90d7851..a471c2b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -12,7 +12,15 @@ python = "^3.10"
[tool.poetry.group.dev.dependencies]
pytest = "^7.4.4"
coverage = "^7.4.0"
+pylint = "^3.0.3"
+autopep8 = "^2.0.4"
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
+
+[tool.pylint.main]
+source-roots = "./"
+
+[tool.pylint.basic]
+docstring-min-length = 0