summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorViljami Ilola <+@hix.fi>2024-03-16 22:05:05 +0200
committerViljami Ilola <+@hix.fi>2024-03-16 22:05:05 +0200
commit4050057c34c67130cf5f1d202ca85cb81985f968 (patch)
tree93dfd6b3eaa4e8cb153266326724afb07d141dcf /pyproject.toml
parent2fd254af8613dba6bbd7bd9f52514229a5287d21 (diff)
make it installable
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f6ab331..179995a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -21,12 +21,15 @@ requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
[tool.poetry.scripts]
-miinaharava = 'sliceitoff.main:main'
+sliceitoff = 'sliceitoff.main:main'
[tool.pytest.ini_options]
pythonpath = [ "src/sliceitoff" ]
-
[tool.pylint.main]
recursive = true
source-roots = ["src/sliceitoff"]
+extension-pkg-whitelist = ["pygame"]
+
+[tool.pylint."messages control"]
+disable = [ "c-extension-no-member" ]