summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorViljami Ilola <+@hix.fi>2024-03-15 16:51:01 +0200
committerViljami Ilola <+@hix.fi>2024-03-15 16:51:01 +0200
commit4bd0381cef63e59801ec05786ec17d567bc4245c (patch)
treee879466e145df6e48c59bc91fe7c7418cdb40ebf /pyproject.toml
parente5aebeba1201cbed041adc0f8d5b8d7a1e007f0f (diff)
dev.sh and dev dependencies
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index dc2ef91..483d69f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "sliceitoff"
-version = "0.1.0"
+version = "0.0-alpha"
description = ""
authors = ["Viljami Ilola <+@hix.fi>"]
readme = "README.md"
@@ -8,8 +8,14 @@ packages = [{include = "sliceitoff", from = "src"}]
[tool.poetry.dependencies]
python = "^3.11"
+pygame = "^2.5.2"
+[tool.poetry.group.dev.dependencies]
+pylint = "^3.1.0"
+pytest = "^8.1.1"
+coverage = "^7.4.4"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"