summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorViljami Ilola <+@hix.fi>2024-04-10 18:04:27 +0300
committerViljami Ilola <+@hix.fi>2024-04-10 18:04:27 +0300
commit6f2eeab32b08c75399c971a52238bdcdc16085b2 (patch)
tree6972e845a3351023d56e8e7e4882262722041b9b /pyproject.toml
parent7b312aab1af3b2c67bc29df1faf46e39947b51fe (diff)
tests for highscores
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 42ca912..16e0c2c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -31,8 +31,10 @@ build-backend = "poetry.core.masonry.api"
[tool.coverage.run]
branch = true
source = ["src/sliceitoff/"]
-omit = ["src/sliceitoff/game/*"] # Game logic and input-needing parts
-
+omit = [
+ "**/__????__.py", # __init__.py and __main__.py files
+ "src/sliceitoff/game/*" # Needs input and graphics.
+]
[tool.pylint.main]
recursive = true