summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml13
1 files changed, 5 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2109569..fb01158 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,32 +3,29 @@ name = "sliceitoff"
version = "0.3-alpha"
description = "Arcade game where one slices play area off avoiding enemies."
authors = ["Viljami Ilola <+@hix.fi>"]
-readme = "README.md"
+readme = "README.txt"
packages = [{include = "sliceitoff", from = "src"}]
[tool.poetry.dependencies]
python = "^3.10"
pygame = "^2.5.2"
-
[tool.poetry.group.dev.dependencies]
pylint = "^3.1.0"
pytest = "^8.1.1"
coverage = "^7.4.4"
-[build-system]
-requires = ["poetry-core"]
-build-backend = "poetry.core.masonry.api"
-
[tool.poetry.scripts]
sliceitoff = 'sliceitoff.main:main'
-
-
[tool.pytest.ini_options]
pythonpath = [ "src/sliceitoff" ]
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
[tool.pylint.main]
recursive = true