summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMarjukka Jämbäck <mjamback@local>2023-11-21 11:16:17 +0200
committerMarjukka Jämbäck <mjamback@local>2023-11-21 11:16:17 +0200
commit2ebfcf29c84b84999b76ff13150ba5a13fd3cac1 (patch)
tree12fcf0504e9682b279cbadd724f026d6cba01b6e /pyproject.toml
parentd13d4860f3d5b51d659379aa8a38742bfe49bf37 (diff)
Make it poetry project and udate install instructions
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..b8351fe
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[tool.poetry]
+name = "kyselma"
+version = "0.1.0"
+description = "Kyselmä - kysele, vastaile ja tutki tuloksia"
+authors = ["Marjukka Jämbäck <mjamback@local>"]
+license = "WTFPL"
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = "^3.11"
+Flask = "^3.0.0"
+flask-sqlalchemy = "^3.1.1"
+psycopg2-binary = "^2.9.9"
+
+[tool.poetry.group.dev.dependencies]
+pytest = "^7.4.3"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"