summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorViljami Ilola <+@hix.fi>2024-04-07 23:25:09 +0300
committerViljami Ilola <+@hix.fi>2024-04-07 23:25:09 +0300
commit6ba20c61a04c688120161f6c5fbb56102f8082ef (patch)
tree33291a2c494b8fe5e126e31b5ce719aa0df0feec /pyproject.toml
parentd2e42bfa99d8bb417d8eaf365d290a071ad49b7f (diff)
exploding sprites and groups as their own. more refactoring.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 13 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ea19274..7d8cf50 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "sliceitoff"
-version = "0.2"
+version = "0.3-alpha"
description = "Arcade game where one slices play area off avoiding enemies."
authors = ["Viljami Ilola <+@hix.fi>"]
readme = "README.md"
@@ -23,15 +23,24 @@ build-backend = "poetry.core.masonry.api"
[tool.poetry.scripts]
sliceitoff = 'sliceitoff.main:main'
+
+
[tool.pytest.ini_options]
pythonpath = [ "src/sliceitoff" ]
+
+
[tool.pylint.main]
recursive = true
source-roots = ["src/sliceitoff"]
extension-pkg-whitelist = ["pygame"]
[tool.pylint."messages control"]
-disable = [
- "too-few-public-methods" # pygame sprites and groups
-]
+disable = [ "too-few-public-methods" ] # pygame sprites and groups
+
+# From given .pylintrc
+[tool.pylint.design]
+max-args = 7
+max-attributes = 8
+max-statements = 20
+min-public-methods = 0