summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 42ca912..16e0c2c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -31,8 +31,10 @@ build-backend = "poetry.core.masonry.api"
[tool.coverage.run]
branch = true
source = ["src/sliceitoff/"]
-omit = ["src/sliceitoff/game/*"] # Game logic and input-needing parts
-
+omit = [
+ "**/__????__.py", # __init__.py and __main__.py files
+ "src/sliceitoff/game/*" # Needs input and graphics.
+]
[tool.pylint.main]
recursive = true